pmachine RSS problem: umlaute !!!!!!!

uns wuerde sehr geholfen sein. wenn ein/e pmachine kenner/in uns einen tipp geben koennte. wie man das rss file auf umlauthoehe bringen koennte. bei jeder umlautverwendung in beitrag wird das rss file naemlich geschmissen. wir haben auch schon eine anfrage im bugforum von pmachine gesetzt. aber leider noch keine antwort erhalten…

womoeglich hat schon jemand eine loesung?! es gibt aber keine belohnung. 😉

update: wunderbar – danke markus! mit intensiver codetechnischer betreuung ist es uns gelungen. in pmachine die fehlenden (!) isowerte auch fuer saemtliche rss versionen nachzutragen (warum machen die sowas?? – das bleibt eine frage an pmachine)…

schoen das. 🙂

als E-Book herunterladen

19 Gedanken zu „pmachine RSS problem: umlaute !!!!!!!

  1. Henning, da kann ich dir nicht weiterhelfen, weil ich ja hier nicht in die Konfiguration reinschauen kann. Laut Sourcecode sieht’s okay aus (bis auf schon oben erwähnten Aufruf), alles andere ist Glaskugelreiben: PB und TB aktiviert? Pfad richtig gesetzt? etc.

  2. Na ja, wo`s hier grad so technisch ist. Vielleicht hast Du da noch nen Tip Marcus: Hier werden die Pings, die ich sende nicht angezeigt. Mein MT sagt mir, dass sie korrekt abgesetzt wurden… Und hier möcht ich die aktuelle Diskussion grad nutzen, um pingen und TB ein wenig weiter zu bringen…. Danke und Gruß

  3. Editier einfach die Datei rss.xml und ersetze die erste Zeile mit folgender:

    <?xml version=”1.0″ encoding=”iso-8859-1″ ?>

    Dann klappt’s auch mit den Umlauten!

    Eure Trackbacks und Pingbacks sind auch nicht richtig gesetzt bzw. laut Anleitung zwar richtig, aber so springt die Seite immer hoch, wenn man den Link anklickt. Das liegt daran, dass der a href=””-Aufruf leer ist. Schaut einfach mal bei meiner Seite in den Quellcode oder schreibt mir eine Mail, dann klappt’s damit auch 😉

  4. huhu – doch, du kannst ihn von hand ändern, und da wird nix mehr überschrieben. Hab ich auch so gemacht. Ging mit pMachine Free und mit pMachine Pro. Von 0.91 hoch bis 2.0 keine Probleme. Es geht ja nur um das encoding; das wird danach auch nicht mehr überschrieben.

  5. von forum zu forum 🙂

    markus. das wird bei mir vollstaendig ueberschrieben… und ich denke nicht. dass ich da noch was falsch mache…

    🙁 serner

    na dann verzichte ich eben auf umlaute… was sind schon umlaute. nicht wahr. machen nur stress. nicht wahr…jaja…:-)

  6. henning – das mit dem nicht tracken koennen auf random scheint ja echt schwierig rauszuklamuesern zu sein…hm..

    bei meinem testtrackaufruf hat ja der moblog dankenswerterweise erfolgreich getrackt. daher sind wir davon ausgegangen. dass das nun doch klappt.

    aber scheint ja nicht so zu sein. eingestellt ist aber bei uns alles auf “JA”…

    henning. wir koennen Dich tracken. aber umgekehrt haengt da wohl was….

    sorry for that – aber wir schaffen das! 😉

    serner

  7. ui – soviele techniker 😉
    super – danke. das problem – marcus ist. dass das xml file von pmachine ja automatisch generiert wird. da nutzt es nichts. wenn ich den header per hand aender. der wird immer wieder ueberschrieben.

    da die pmachine aber sonst auf umlaute normal reagiert. nehme ich an. dass die richtig eingestellt sind. in der rss fabric ist auch die sprache deutsch eingestellt…

    ich habe mal noch eine mail ans supportforum gesetzt. vor dem update gabs damit ja keine probleme im rss file…

    naja. – aber danke auch fuer den hinweis mit dem hochsprung tracken. ist mir auch aufgefallen. aber ich dachte. dass ist ein feature. 😉 mach ich mich heute abend dran.

    merci fuer die schnelle antwort. wir sind platterdings gluecklich!

    serner

  8. markus – danke fuer den trackback reload tipp. habe ich gleich anhand quellcodesniffing bei dir eingebaut. merci! – falls man was fuer dich mal tun kann…:-)

    serner <code:kampf on>

  9. merci markus –

    das wars. jetzt funktionierts auch mit ä ö ü. 🙂 ist schon strange. dass sie das nur fuer eine version auffuellen und die anderen variablen einfach leer lassen…

    die wege von pmachine sind…

    serner

  10. Jaja, die pmaschine…
    Sehr schön :-)) Das freut mich, dass es jetzt klappt! Wieder ein Tagespensum Gutes-Tun hinter mich gebracht ;o)

  11. Also, dann müssen wir’s jetzt doch wohl technisch machen 🙂

    Geh in deinen pm-Ordner, den du am Anfang umbenannt hast. Gehe dort in den cp-Ordner. Dort findest du eine Datei rss.class.php. Suche in dieser Datei nach

    //————————————-
    // Build RSS File
    //————————————-

    Nach ein paar Zeilen steht dort

    case “0.92” : $encoding = “”;

    Ersetze diese Zeile mit:

    case “0.92” : $encoding = “iso-8859-1”;

    Speichern bzw. neu hochladen – fertig! (Hoffentlich.)

  12. Hi,
    ich habe ja auch pMachine, krieg aber nicht den richtigen trackback- bzw. pingback-Pfad raus:
    Kannst Du mir sagen, wie der ‘korrekt’ aussieht?
    Grüße,
    Stephan

  13. Den, oder die beiden, die Du jew. unter dem Eintrag hast, die also auf trackbacks.php und pingbacks.php gehen und jew. auch die Eintrags-ID angehängt haben; also die zu den beiden Pop-Ups. Ähm, verständlich?

  14. soso – naja. wir hatten das auch bewusst nach der “offiziellen” nomenklatur gesetzt: “userinnen” als “user + userinnen” verstanden. 😉 aber bitte. je mehr trackbacker es gibt. desto eher kann ueberhaupt so was wie ein trackbacknetzwerk entstehen…ist ja spaerlich gesaet…

  15. hallo stephan,
    welchen pfad meinst Du genau? den, um einen anderen artikel zu verlinken? oder den, den Du fuer deinen artikel brauchst?

    z.b. der trackbackpfad zu diesem artikel sieht so aus:
    trackback link

    serner

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.